Metrics historical data failed queries

Incident Report for Datadog US1

Resolved

Our metrics system has recovered and all historical metrics are now queryable.
Posted 11 months ago. May 13, 2024 - 17:55 EDT

Update

The system continues to recover. Data is available, but some results may be slow or incomplete until full recovery. Our teams continue to monitor the incident.
Posted 11 months ago. May 13, 2024 - 17:18 EDT

Monitoring

A fix has been implemented. While the system continues to recover, data will be available but some results may be slow or incomplete until full recovery is complete.
Posted 11 months ago. May 13, 2024 - 16:17 EDT

Update

We are continuing to work on a fix for this issue.
Posted 11 months ago. May 13, 2024 - 15:40 EDT

Update

We are continuing to work on a fix for this issue.
Posted 11 months ago. May 13, 2024 - 14:41 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted 11 months ago. May 13, 2024 - 14:14 EDT

Investigating

We are investigating queries failing for historical data for metrics, impacting timeframes more than one day ago.
Queries for recent data are not affected by this incident.
Posted 11 months ago. May 13, 2024 - 13:59 EDT
This incident affected: Cloud Cost Management and Metrics and Infra Monitoring.