Delayed monitors notifications

Incident Report for Datadog US1

Resolved

Combined into single incident
Posted Sep 24, 2020 - 12:37 EDT

Update

We are continuing to investigate this issue.
Posted Sep 24, 2020 - 11:47 EDT

Investigating

We're investigating an issue with delayed metric monitors since 13:40 UTC.
Posted Sep 24, 2020 - 10:00 EDT
This incident affected: Monitors.