Delayed Distribution Metrics

Incident Report for Datadog US1

Resolved

This incident has been resolved. All distribution metrics are being processed and monitors are no longer disabled for distribution metrics.
Posted Oct 11, 2024 - 18:20 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 11, 2024 - 17:13 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 11, 2024 - 16:35 EDT

Identified

The issue has been identified and remediation steps are underway.
Posted Oct 11, 2024 - 15:57 EDT

Investigating

We are investigating increased latency processing Distribution Metrics.
As a result of this issue, some users may see delays or gaps for distribution metrics on graphs.
To prevent spurious alerts, we have temporarily disabled monitors based on distribution metrics.
Posted Oct 11, 2024 - 15:52 EDT
This incident affected: Metrics and Infra Monitoring and Monitors.