Delayed AWS Metrics
Incident Report for Datadog US1
Resolved
This incident has been resolved.
Posted Apr 20, 2022 - 13:14 EDT
Monitoring
AWS Metric processing latency has returned to normal and monitors on AWS Metrics are reenabled.

We continue to monitor impacted systems.
Posted Apr 20, 2022 - 13:13 EDT
Identified
We have identified the issue impacting AWS Metrics processing latency and have implemented a fix. AWS Metrics are beginning to backfill and we are monitoring the recovery.

Monitors on AWS Metrics remain disabled.
Posted Apr 20, 2022 - 13:08 EDT
Update
We are continuing to investigate this issue and will provide updates as we learn more.
Posted Apr 20, 2022 - 12:52 EDT
Investigating
We are investigating increased latency processing AWS Metrics.
As a result of this issue, some users may see delays or gaps in graphs that contain these metrics.
To prevent spurious alerts, we have temporarily disabled monitors based on this data.
Posted Apr 20, 2022 - 12:22 EDT
This incident affected: Cloud Integrations.