Delayed AWS, GCP, and Azure metrics, delayed notifications
Incident Report for Datadog
Resolved
This incident has been resolved.
Posted Feb 22, 2021 - 17:21 EST
Monitoring
Azure and GCP metrics have caught up and alerts on these metrics have been enabled.

Additionally, notification latency is back to normal.
Posted Feb 22, 2021 - 17:04 EST
Update
AWS metrics have caught up and alerts on these metrics have been enabled.
Posted Feb 22, 2021 - 16:55 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 22, 2021 - 16:44 EST
Update
We are continuing to investigate this issue.
Posted Feb 22, 2021 - 16:42 EST
Investigating
We’re actively investigating increased intake latencies for AWS, GCP, and Azure metrics. As an effect, there might be delays in graphs displaying these metrics.

We’re also investigating increased latencies with all notifications.

To avoid spurious alerts we’ve temporarily disabled alerts on these metrics.
Posted Feb 22, 2021 - 16:34 EST
This incident affected: Alerting Engine, API Crawlers, and Metrics Pipeline.