Delayed CI Visibility data

Incident Report for Datadog US1

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 19:32 EDT

Identified

We have identified the underlying issue and are working on a fix.

It is important to note that no data has been lost, and it will be backfilled and available once the service is operational again.
Posted Jun 25, 2026 - 19:24 EDT

Investigating

We are investigating increased latency processing CI Visibility data.

As a result of this issue, some users may see delays with pipeline executions.
Posted Jun 25, 2026 - 19:23 EDT
This incident affected: CI Visibility.