Elevated error rates for Metrics Submissions APIs
Incident Report for Datadog US1
Resolved
This incident has been resolved. We traced the issue back to an expired certificate used by client libraries (such as datadogpy or terraform-provider-datadog) to interact with some of our APIs.
Posted Jun 04, 2022 - 21:21 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2022 - 21:03 EDT
Identified
We have identified the underlying issue and are working on a fix.

Please note that the Datadog Agent and Client Libraries will buffer data or retry to avoid data loss.
Posted Jun 04, 2022 - 20:59 EDT
Investigating
We are investigating elevated error rates for Metrics Submission APIs.
As a result of this issue, submitting new metric data through the API might fail temporarily.
Posted Jun 04, 2022 - 20:44 EDT
This incident affected: Metrics and Infra Monitoring.