Pagerduty Monitor Notifications Delayed

Incident Report for Datadog US1

Resolved

PagerDuty notifications deliveries are back to normal.
Posted Aug 28, 2025 - 05:05 EDT

Monitoring

We are observing some recovery of notifications delays and continue to monitor the situation. Please follow our integration status page for details https://datadogintegrations.statuspage.io/
Posted Aug 28, 2025 - 04:03 EDT

Investigating

Monitor Notifications are delayed for Pagerduty.
Posted Aug 28, 2025 - 00:39 EDT
This incident affected: Monitors.