User actions like user creation/user edits intermittently failing/slow

Incident Report for Datadog US1

Resolved

This incident has been resolved.
Posted Jul 28, 2023 - 14:59 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2023 - 14:57 EDT

Investigating

User specific actions like user creation or edits to users are intermittently slow/failing
Posted Jul 28, 2023 - 14:53 EDT