Delayed AWS, GCP, Azure, SaaS integrations Metrics and Logs

Incident Report for Datadog US1

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 15:19 EDT

Update

Data flow has been restored for new incoming data. We are currently backfilling historical data.
Posted Oct 14, 2025 - 14:44 EDT

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Oct 14, 2025 - 13:43 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 14, 2025 - 13:29 EDT

Investigating

We are investigating increased latency processing AWS, GCP and Azure Metrics.
As a result of this issue, some users may see delays or gaps in graphs that contain these metrics.
To prevent spurious alerts, we have temporarily disabled monitors based on this data.
Posted Oct 14, 2025 - 13:14 EDT
This incident affected: Metrics and Infra Monitoring.