Delayed Metrics for APM and distribution metrics

Incident Report for Datadog US1

Resolved

APM metrics are now processing live.
Posted Nov 05, 2025 - 12:57 EST

Update

The distribution metrics should be back to processing live, without latency. APM metrics are still being delayed, and we're actively working at getting it back to live.
Posted Nov 05, 2025 - 11:59 EST

Update

We have identified the root cause, and scaled up the processing to catch up with the lag.
Posted Nov 05, 2025 - 11:25 EST

Identified

We are investigating increased latency processing Metrics from APM and distribution metrics.
As a result of this issue, some users may see delays or gaps for metrics on graphs.
To prevent spurious alerts, we have temporarily disabled monitors based on this data.
Posted Nov 05, 2025 - 10:42 EST
This incident affected: APM, Metrics and Infra Monitoring, and Monitors.