Errors Pulling Container Images

Incident Report for Datadog US1

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 21:29 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2026 - 21:21 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 02, 2026 - 20:55 EDT

Investigating

We are investigating errors pulling Datadog container images from registry.datadoghq.com. As a result of this issue, some users may be unable to download or deploy the Datadog Agent, Cluster Agent, and other Datadog container images. Containers that are already running are not affected.
Posted Jul 02, 2026 - 20:25 EDT
This incident affected: Container Registry.