Notifications to Pagerduty, VictorOps, Slack, Webhook, Microsoft Teams and OpsGenie are not delivered

Incident Report for Datadog US1

Resolved

Between approximately 9:42 AM and 10:38 AM ET on April 10, we observed delivery failures for customers in the US1, AP1, and AP2 regions. During this window, notifications to the following integrations were delayed or temporarily undelivered:

• PagerDuty
• Slack
• Microsoft Teams
• Webhooks
• Jira
• ServiceNow
• OpsGenie
• VictorOps
• BigPanda
• Zendesk
• Sumologic

All delayed notifications have been replayed with the following exceptions: PagerDuty pages and Slack notifications queued during the outage window were not replayed, as they were no longer actionable at the time of recovery. Webhook notifications will be reprocessed and delivered at a later date.

No monitoring data was lost during this incident. Monitor evaluations continued normally — only the delivery of triggered notifications was affected.

Thank you for your patience.
Posted Apr 10, 2026 - 16:59 EDT

Update

Webhooks and Slack notifications are still catching up.
Posted Apr 10, 2026 - 16:13 EDT

Update

Webhooks and Slack notifications are still catching up.
Posted Apr 10, 2026 - 15:44 EDT

Update

Webhooks and Slack notifications are still catching up.
Posted Apr 10, 2026 - 15:02 EDT

Update

Notifications for ServiceNow and Microsoft Teams are now caught up. Webhooks and Slack notifications are still catching up.
Posted Apr 10, 2026 - 14:33 EDT

Update

Notifications for JIRA are now caught up.
Posted Apr 10, 2026 - 13:37 EDT

Update

Notifications for Opsgenie, VictorOps, BigPanda, Zendesk, and Sumologic are caught up. Webhooks, Microsoft Teams, Slack, JIRA, and ServiceNow are still catching up.
Posted Apr 10, 2026 - 13:12 EDT

Update

We are still catching-up on past notifications that may have been delayed.
Posted Apr 10, 2026 - 12:15 EDT

Update

We are still catching-up on past notifications that may have been delayed.
Posted Apr 10, 2026 - 11:59 EDT

Monitoring

New notifications are now successfully delivered, and we are catching-up on past notifications that may have been delayed
Posted Apr 10, 2026 - 11:42 EDT

Update

New notifications are now successfully delivered, and we are catching-up on past notifications that may have been delayed.
Posted Apr 10, 2026 - 11:42 EDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 10, 2026 - 11:23 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 10, 2026 - 11:00 EDT

Investigating

We are investigating an issue to send notifications to Pagerduty, VictorOps, Slack, Webhook, Microsoft Teams and OpsGenie.
Posted Apr 10, 2026 - 10:54 EDT
This incident affected: Monitors.