Delayed Traces and Spans in APM

Incident Report for Datadog US1

Resolved

The incident is now resolved. APM trace ingestion and all downstream systems, including monitors, have fully recovered and are up to date.
Posted May 13, 2025 - 18:28 EDT

Monitoring

We are monitoring a fix with to increased latency processing in APM Metrics. APM data in live view is current but distributed tracing metrics are delayed by 20 minutes. Monitors sourced from the data are impacted until the data becomes current.
Posted May 13, 2025 - 16:25 EDT

Investigating

As a result of the issue we are monitoring delays in Monitors Evaluation
Posted May 13, 2025 - 15:33 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 13, 2025 - 15:20 EDT

Investigating

We are investigating increased latency processing Traces and Spans in APM
As a result of this issue, some users may see missing or delayed traces and Spans starting at 18:33 UTC.
Posted May 13, 2025 - 15:06 EDT
This incident affected: APM and Monitors.