Delayed monitor notifications
Incident Report for Datadog
Resolved
This incident has been resolved.
Posted 9 months ago. Feb 09, 2018 - 12:32 EST
Identified
Monitor processing is currently delayed. As a result you might experience a delay in notifications for monitors. We are actively working to resolve the issue.

Dashboards are fully operational.
Posted 9 months ago. Feb 09, 2018 - 12:19 EST