Degraded Web Application Performance

Incident Report for Datadog US1

Resolved

This incident has been resolved.
Posted May 13, 2026 - 11:53 EDT

Monitoring

We have deployed a fix and we are monitoring the results. We will provide another update once the issue is fully resolved.
Posted May 13, 2026 - 11:36 EDT

Investigating

We are investigating degraded performance in the Database Monitoring pages and APM service pages.

During this time, some customers may be experiencing:
- The DBM database list page failing to load or displaying zero databases
- 503 errors when attempting to access database instance views
- Inability to view or interact with Database Monitoring data in our US1 datacenter
- The APM service page failing to load
Posted May 13, 2026 - 11:16 EDT
This incident affected: APM and Database Monitoring.