API errors for monitors endpoint
Incident Report for Datadog
Resolved
This incident has been resolved.
Posted Jun 08, 2020 - 16:20 EDT
Update
Delays in monitor data has been resolved, all data is up to date.
Posted Jun 08, 2020 - 16:20 EDT
Monitoring
Delayed data for synthetic test creation and API errors for monitor API calls have been address for all but a small subset of customers.
Posted Jun 08, 2020 - 16:03 EDT
Update
Clarification: alerting and notifications are fully operational, only historical monitor status data is delayed in the UI and API. No data has been lost and any delayed data will be restored.
Posted Jun 08, 2020 - 15:15 EDT
Update
An issue impacting indexing alerting is affecting API calls as well as delays in monitor data, including synthetic monitors. Monitors continue to be evaluated normally and any delayed data will be restored.
Posted Jun 08, 2020 - 15:08 EDT
Update
We've identified the issue with delayed indexing of new synthetics monitors related to this issue and are working to backfill the data. No data has been lost.
Posted Jun 08, 2020 - 15:06 EDT
Update
We are investigating reports of similar errors occurring with the synthetics API
Posted Jun 08, 2020 - 14:49 EDT
Identified
We have identified an issue impacting the monitor API endpoint resulting in 502 responses and are working on a resolution.
Posted Jun 08, 2020 - 14:19 EDT
This incident affected: Alerting Engine, API, and Synthetics.