Delayed Monitors Notifications

Incident Report for Datadog US1

Resolved

The issue is now resolved.
Posted Sep 21, 2026 - 06:30 EDT

Monitoring

We are monitoring the issue.
Posted Sep 21, 2026 - 06:22 EDT

Identified

We identified the issue and is working on a fix.
Posted Sep 21, 2026 - 06:00 EDT

Investigating

We are investigating delayed evaluations for metric, service check, composite, and SLO monitors in US1 which began at Sep 21, 2026, 9:18 AM UTC.
Posted Sep 21, 2026 - 05:44 EDT
This incident affected: Monitors.