Delayed events triggered by emails

Incident Report for Datadog US1

Resolved

The issue is now resolved. All events from emails are being timely processed and we went through the backfill.
Posted Sep 20, 2026 - 02:53 EDT

Investigating

We are investigating increased latency processing Events coming from inbound emails. As a result of this issue, some users may see delays or gaps in the event stream or for event queries on dashboards and for events based workflows such as on-call notifications
Posted Sep 20, 2026 - 01:17 EDT
This incident affected: Incident Response.