Login Issues

Incident Report for Datadog US1

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 20:17 EDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 25, 2025 - 17:34 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 25, 2025 - 15:24 EDT

Investigating

We are investigating user login issues related to reCAPTCHA for customers using password login. If you experience an issue with reCAPTCHA, refreshing the page can often mitigate the issue.

Please note that data processing and alerts are not affected by this incident.
Posted Mar 25, 2025 - 15:03 EDT
This incident affected: Web Application.