Web Application Not Loading

Incident Report for Datadog US1

Resolved

This incident has been resolved as of 2:32PM ET.
Posted Nov 19, 2025 - 14:44 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2025 - 14:37 EST

Update

We continue investigating the issue with web application. Data processing and alerting remain operational.
Posted Nov 19, 2025 - 14:28 EST

Investigating

We are investigating loading issues on our web application. As a result, some users might be getting errors when loading the web application.
Posted Nov 19, 2025 - 14:08 EST
This incident affected: Web Application.