Users are unable to acknowledge, escalate, or resolve On-Call Pages

Incident Report for Datadog US1

Resolved

The issue is now resolved.
Posted Sep 25, 2026 - 11:38 EDT

Monitoring

We are monitoring the issue.
Posted Sep 25, 2026 - 11:29 EDT

Identified

We have identified the issue with pages and are applying mitigations.
Posted Sep 25, 2026 - 11:23 EDT

Update

We are investigating an issue with users unable to acknowledge, escalate, or resolve On-Call Pages.
Posted Sep 25, 2026 - 11:17 EDT

Investigating

We are investigating an issue with users unable to acknowledge on call pages
Posted Sep 25, 2026 - 11:11 EDT
This incident affected: Incident Response.