Delayed APM metric ingestion

Incident Report for Datadog US1

Resolved

All impact related to APM metrics has been resolved. A separate incident has been created to track the remaining impact in live process data.
Posted Dec 12, 2025 - 16:52 EST

Identified

We have identified the issue affecting ingestion delays in apm and process metrics and are working on recovery
Posted Dec 12, 2025 - 15:53 EST

Update

We are currently investigating lag in ingesting apm and process metrics, which affects monitor evaluation and in some cases led to incorrect monitor alerts.
Posted Dec 12, 2025 - 14:26 EST

Update

We are continuing to investigate this issue.
Posted Dec 12, 2025 - 13:55 EST

Investigating

We are currently investigating lag in ingesting apm metrics, which affects monitor evaluation.
Posted Dec 12, 2025 - 13:37 EST
This incident affected: Metrics and Infra Monitoring.