Dashboards Not Loading

Incident Report for Datadog US1

Resolved

All errors stopped as of 12:02ET. This incident has been resolved.
Posted Nov 17, 2025 - 12:20 EST

Monitoring

The rollout with a fix is in progress, and we're no longer seeing errors, and are currently monitoring the incident and we are on the path of recovery.
Posted Nov 17, 2025 - 12:12 EST

Identified

The issue has been identified and we taking measures to mitigate the issue, as well as working on a fix.
Posted Nov 17, 2025 - 11:40 EST

Investigating

We are investigating loading issues on the dashboard pages. As a result, some users might be getting errors when loading the web application.

Please note that data processing and alerts are not affected by this incident.
Posted Nov 17, 2025 - 11:23 EST
This incident affected: Web Application.