Delays ingesting metrics, service checks, and events
Incident Report for Datadog
Resolved
We've resolved delays in ingesting metrics, events, and check runs. Customers may observe gaps when querying these data types from 22:07 UTC to 23:11 UTC.

We've finished processing the alerting backlog, and live data is current.
Posted Apr 21, 2020 - 21:45 EDT
Monitoring
We've implemented a fix and are currently monitoring recovery. Alerts have been re-enabled and we are processing the backlog.
Posted Apr 21, 2020 - 19:55 EDT
Update
We're continuing to work to resolve the issue, and are seeing signs of recovery in metrics, event, and check run ingestion. To avoid spurious alerts while we we recover, alerts remain disabled.
Posted Apr 21, 2020 - 19:37 EDT
Identified
We've identified the issue causing delays and are implementing measures to recover.
Posted Apr 21, 2020 - 19:01 EDT
Update
We are continuing to investigate this issue.
Posted Apr 21, 2020 - 18:31 EDT
Update
We've identified additional delays with event intake and check runs. To avoid spurious alerts, we've temporarily disabled alerts for these data types.
Posted Apr 21, 2020 - 18:30 EDT
Investigating
We’re investigating increased metric latencies. As a result, graphs may be delayed. To avoid spurious alerts, we’ve temporarily disable alerts for Metric Monitors.
Posted Apr 21, 2020 - 18:27 EDT
This incident affected: Alerting Engine, Event Pipeline, and Metrics Pipeline.