Delayed data streams data

Incident Report for Datadog US1

Resolved

This incident has been resolved.
Posted Jul 10, 2026 - 11:59 EDT

Monitoring

A fix has been implemented and we are monitoring the results. A small percentage of data sent between 6:23 UTC and 14:43 UTC is still being backfilled.
Posted Jul 10, 2026 - 11:18 EDT

Update

We are continuing to investigate the issue.
Posted Jul 10, 2026 - 10:35 EDT

Investigating

We are currently investigating an issue affecting Data Streams Monitoring (DSM) in our US1 datacenter. As a result, data stream latency metrics may be delayed or not updating for some users. If you have monitors configured on those metrics, they may fail to alert as expected during this incident. We are not aware of any data loss at this time. Our engineering team is actively working on a fix, and we'll follow up with more information shortly.
Posted Jul 10, 2026 - 10:09 EDT
This incident affected: Data Streams Monitoring.