Degraded Web Application Performance & Monitor Evaluations

Incident Report for Datadog US1

Resolved

This incident has been resolved.
Posted Jul 09, 2025 - 17:46 EDT

Monitoring

We've implemented a fix and we're seeing recovery in monitor evaluations and dashboards, we'll continue to investigate and monitor for further impact
Posted Jul 09, 2025 - 17:26 EDT

Identified

We've identified a possible root cause and we're actively working on mitigating the impact
Posted Jul 09, 2025 - 17:06 EDT

Investigating

We're investigating an issue with our metrics and monitor evaluations, causing degraded web application performance and skipped monitors
Posted Jul 09, 2025 - 16:46 EDT
This incident affected: Cloud Cost Management, Monitors, and Web Application.