Dashboard list page failing to load
Incident Report for Datadog US1
Resolved
This incident has been resolved.
Posted Dec 15, 2020 - 11:58 EST
Investigating
We're investigating reports that the dashboard list page is failing to load for some customers
Posted Dec 15, 2020 - 11:57 EST
This incident affected: Web Application.