Host Tags, Service Checks, and Datadog Events Delayed Evaluation

Incident Report for Datadog US1

Resolved

This incident has been resolved.
Posted Sep 29, 2025 - 15:43 EDT

Monitoring

Service Check and Datadog Events monitor evaluation has recovered and data is up-to-date. Host tag updates are still recovering and stale host tags may appear in the frontend.
Posted Sep 29, 2025 - 15:36 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 29, 2025 - 14:20 EDT

Investigating

We’re currently investigating an issue causing delayed processing of host tag updates, Service Checks and Datadog Events, which may result in stale data appearing in the frontend. Our team is actively working to mitigate and fully resolve this. I’ll follow up as soon as the issue has been resolved. To prevent spurious alerts, we have temporarily disabled monitors based on this data.
Posted Sep 29, 2025 - 14:17 EDT
This incident affected: Metrics and Infra Monitoring and Monitors.