Monitors - Delayed Evaluation

Incident Report for Datadog US1

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 09:52 EDT

Update

The incident has fully recovered. The service is now fully operational.
Posted Apr 16, 2025 - 09:50 EDT

Investigating

We are investigating delays in Monitors Evaluation, which began at 12:45 UTC.
Posted Apr 16, 2025 - 09:37 EDT
This incident affected: Monitors.