Delayed CICD Optimization, Code Coverage, Code Security, and DORA data

Incident Report for Datadog US1

Monitoring

We are monitoring the issue.
Posted Sep 03, 2026 - 15:01 EDT

Identified

We identified the issue.
Posted Sep 03, 2026 - 13:59 EDT

Monitoring

We are monitoring the issue.
Posted Sep 03, 2026 - 13:45 EDT

Identified

We identified the issue.
Posted Sep 03, 2026 - 13:27 EDT

Investigating

We are investigating increased latency processing CICD Optimization, Code Coverage, Code Security, and DORA data.
As a result of this issue, some users may see delays with test runs and pipeline executions.
Posted Sep 03, 2026 - 13:20 EDT
This incident affects: CI Visibility.