Delayed Events

Incident Report for Datadog US1

Resolved

This incident is resolved. There's no more delay for the processing of Events, nor impact on the event stream, event based widgets and event based monitors.
Posted Jan 18, 2026 - 09:24 EST

Update

Recovery is in progress and the new estimated time of recovery would be 14h30 UTC.
Posted Jan 18, 2026 - 08:26 EST

Update

We have identified the issue and scaled up for recovery, with a recovery estimated to be around 14h30 UTC. We'll continue to give updates as recovery progresses.
Posted Jan 18, 2026 - 07:35 EST

Identified

We are investigating increased latency processing Events.
As a result of this issue, some users may see delays or gaps in the event stream or for event based widgets or event based monitors.
Posted Jan 18, 2026 - 07:33 EST
This incident affected: Metrics and Infra Monitoring.