Delayed Processing for a Subset of Metrics
Incident Report for Datadog US1
Resolved
This incident has been resolved.
Posted Apr 12, 2022 - 11:16 EDT
Monitoring
We have deployed a fix and we are monitoring the results. We are currently backfilling some delayed data and will provide another update once the issue is fully resolved.
Posted Apr 12, 2022 - 10:24 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 12, 2022 - 09:18 EDT
Update
Fix has been implemented and we are monitoring recovery for delayed metrics and monitors. This only impacts distribution metrics and associated monitors.
As a result of this issue, some customers might also experience errors or incomplete data on some APM pages. We expect full recovery once all the delayed data has been backfilled.
Posted Apr 12, 2022 - 09:12 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 12, 2022 - 08:39 EDT
Update
We are continuing to investigate this issue.
Posted Apr 12, 2022 - 07:22 EDT
Investigating
We are investigating increased latency processing Processing for a Subset of Metrics.
As a result of this issue, some users may see delays or gaps for a subset of their metrics on graphs.
To prevent spurious alerts, we have temporarily disabled monitors based on this data.
Posted Apr 12, 2022 - 07:13 EDT
This incident affected: APM Services, Metrics, Monitors, and Synthetics.