Real user monitoring, distribution and custom processes metrics delayed

Incident Report for Datadog US1

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 13:28 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2026 - 13:12 EDT

Update

The RUM delays have been resolved. We're continuing to mitigate the issues on distribution metrics.
Posted Jul 29, 2026 - 12:53 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 29, 2026 - 12:35 EDT

Update

We are continuing to investigate this issue.
Posted Jul 29, 2026 - 11:42 EDT

Investigating

We are currently investigating an issue delaying the ingestion of Real User Monitoring (RUM) measure metrics, custom process metrics, and a subset of distribution metrics for some customers.

As a result, some users may see delays or gaps in RUM, custom process, and distribution metrics. To prevent false alerts caused by delayed data, affected monitors will not notify and will automatically resume once current data is available. All other monitors will operate normally. No data has been lost.

We will provide further updates as the situation progresses.
Posted Jul 29, 2026 - 11:41 EDT
This incident affected: Metrics and Infra Monitoring, Monitors, and RUM.