Delayed RUM data

Incident Report for Datadog US1

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 11:16 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2025 - 10:46 EDT

Investigating

We are investigating increased latency processing RUM data.
As a result of this issue, some users may see gaps or delays in RUM graphs as well as empty or partial query results on RUM Sessions, RUM Analytics, RUM Application, and Error Tracking pages.
Posted Sep 02, 2025 - 10:13 EDT
This incident affected: RUM.